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Creation and Management of
Blocks and DIN Sheet Formats

Formats A0 · A1 · A2 · A3 · A4

Complete guide to importing, creating and managing DXF/DWG blocks in TopoCal,
together with the handling of DIN print formats in every standard size.

Includes connectivity with AutoCAD, ZWCAD and GstarCAD.

■ 2 block types ■ 5 DIN sheet formats ■ CAD connectivity ■ PDF output
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INT Introduction
Simple blocks vs. DIN sheet formats

TopoCal handles two clearly distinct concepts that are often confused: simple blocks (small reusable
symbols such as trees, manholes, North arrows…) and DIN sheet formats (the predefined paper layouts
A0 to A4 used for plotting and PDF output). Knowing which one to use for each task is the first step.

Simple block vs. DIN sheet format

Simple block DIN sheet format

Reusable graphic symbol Predefined sheet layout for plotting

Inserted at a point at any scale Inserted around the drawing, fixed scale

Example: tree, manhole, vehicle Example: A1 sheet 594 × 841 mm with title block

Stored in …\TopoCal 2026\Blocks\ Stored in …\TopoCal 2026\Formats\

Inserted from the Blocks menu Inserted from Insert > Predefined Block

Simple block DIN sheet format

Installation paths and backup
Custom blocks and DIN sheet formats are stored in the user folder. Before reinstalling or updating TopoCal
it is essential to back up these two subfolders to avoid losing your customised work:

C:\Program Files (x86)\TopoCal 2026\Blocks\ Blocks folder

C:\Program Files (x86)\TopoCal 2026\Formats\ DIN formats folder

■ Backup before reinstalling
Copy the Blocks and Formats folders to a safe location before any reinstall. After installing the new version,
paste them back to recover all your customisations.
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CAD 1. CAD Connectivity
AutoCAD · ZWCAD · GstarCAD · CAD ribbon

To work with DXF files later than R12, or with DWG files, TopoCal can connect automatically to
GstarCAD, ZWCAD or AutoCAD through the Cad menu in the menu bar. Any version installed is enough
(even trial versions).

1.1 Connecting to AutoCAD
The process is immediate: from the Cad menu choose the AutoCAD version installed. TopoCal launches
AutoCAD in the background and both applications stay linked. The AutoCAD icon appears in the Windows
taskbar.

Steps to connect to AutoCAD

1
Choose the version
Cad menu → pick your AutoCAD version (2018, 2019, 2020…). TopoCal starts AutoCAD
automatically.

2
Confirm the connection
A dialog appears: «Now connecting with AutoCAD vXX». Click OK.

3
Check the taskbar
The AutoCAD icon appears in the Windows taskbar, confirming the link is active.

Confirmation dialog of the active connection with AutoCAD
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Exporting from TopoCal to AutoCAD
Cad menu → Paste in CAD. The export window opens with these options:

PNT

Points and entities
Choose what to include: point number, name, code, decimals, text height and direction.

POL

Polylines
Sends 2D and 3D polylines while preserving the original layer.

LAY

Layers
Maintains the layer structure used in TopoCal.

BLK

Custom blocks
Transfers blocks inserted in the TopoCal drawing.

Cad ribbon — actions available when AutoCAD is connected

Once connected, the Cad ribbon offers the following actions:

PEG
Paste in CAD
Sends the current drawing to AutoCAD as new entities.

OBT
Get from CAD
Imports the AutoCAD active drawing into TopoCal.

RDX
Read DXF
Loads a DXF file via AutoCAD (any DXF version).

RDW
Read DWG
Loads a DWG file via AutoCAD.

SDX
Send DXF
Saves the current TopoCal drawing as DXF.

SDW
Send DWG
Saves the current TopoCal drawing as DWG.
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CAP
Layer manager
Filters which layers travel between both applications.

AJU
Settings
Adjusts the colour mapping, units and precision.

DSC
Disconnect
Closes the link with AutoCAD; TopoCal keeps running on its own.
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1.2 Connecting to ZWCAD / GstarCAD
Both CAD platforms are fully compatible with the AutoCAD connector. The process is identical: open the
Cad menu and select the installed version. TopoCal launches the CAD in the background and links to it
just as with AutoCAD.

Known limitations

Feature Behaviour

Polyline import Identical to AutoCAD

Block import Identical to AutoCAD

Hatch import Not supported in some ZWCAD versions

Dynamic blocks Imported as static blocks

3D solids Converted to 3D faces

Connection workflow

1
Install the CAD
Make sure ZWCAD or GstarCAD is installed. Any version is valid, including trial.

2
Open the Cad menu
From TopoCal go to Cad → choose your version of ZWCAD or GstarCAD.

3
Confirm the connection
A dialog confirms that the CAD link is active.

4
Use the Cad ribbon
All ribbon options work the same as with AutoCAD.

■ Choose the right CAD
If you have several CADs installed, TopoCal connects to the one selected in the menu. You can only have
one active connection at a time; disconnect before switching to a different CAD.
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DXF 2. Direct DXF Block Import
DXF R12 · layer selection · automatic blocks

If you only have DXF R12 files, TopoCal imports them directly without needing any CAD. From the File
menu choose Open and select the DXF file. The application analyses its contents and shows a layer
selection dialog.

1
Open the DXF file
File → Open → select the .dxf file from disk.

2
Review the layer dialog
TopoCal lists every layer with its colour, number of entities and a checkbox.

3
Tick the layers you need
Tick only the layers you want to import. The «Selected» row at the foot updates the count.

4
Confirm with OK
Press OK. The layers and any blocks defined in the DXF are loaded into TopoCal.

Layer selection window when importing a DXF file
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■ Blocks included automatically
When you import a DXF, all the blocks defined in it are also imported, exactly as when using the CAD
connectivity. No extra step is needed to recover the blocks from the file.

■ DXF later than R12
If you receive a DXF in a newer version (2004, 2007, 2010, 2013…) and you do not have any CAD installed,
ask the sender to export it as 'DXF AutoCAD R12/LT2'. This option is available in every modern CAD under
'Save as'.

Block sources on the internet
• Look for topographic or architectural blocks in DXF R12 format for direct import.

• For blocks in DWG or later DXF, use the CAD connectivity (Section 1).

• Downloaded blocks must be copied manually to …\TopoCal 2026\Blocks\ so they appear in the
insertion menu.
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BLO 3. Blocks and DIN Sheet Formats
Create · insert · sheet formats · print

This section covers the complete workflow with blocks and DIN sheet formats: from creating your own
custom blocks to printing the final plan in PDF, going through the insertion of standard sheet formats from
A0 to A4.

Blocks and DIN Sheet Formats

INS

Insert block
Inserts a block from the library at a chosen point and scale.

IFM

Import format
Loads a new DIN sheet format file into the application.

IBQ

Import block
Loads a new block file (DXF/DWG) into the library.

EDT

Edit block
Modifies the geometry of an existing block.

MOV

Move block
Repositions an inserted block in the drawing.

DEL

Delete block
Removes a block from the drawing or library.

PIN

Insertion point
Defines the reference point for inserting the block.

VIS

Show / hide blocks
Toggles the visibility of blocks in the drawing.
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3.1 Creating user blocks
There are three ways of creating a custom block. Choose the one that best fits the origin of the geometry:

A
A. From a drawing in TopoCal
Draw the symbol with polylines, points and texts in TopoCal. Then go to Blocks → Create from
selection, mark the elements and define the insertion point. The block is saved in …\TopoCal
2026\Blocks\.

B
B. From an imported DXF
Open a DXF that already contains the block. TopoCal imports all blocks automatically; you only need
to give the block a name and save it to the library.

C
C. From a CAD via the connector
With AutoCAD/ZWCAD/GstarCAD connected, use Get from CAD to retrieve the block directly.
TopoCal preserves the original insertion point and layer.

■ Insertion point
The insertion point is the reference around which the block is positioned, scaled and rotated. Place it where
you want the block to «hang» — typically the centre of the symbol or one of its corners. A poorly chosen
insertion point makes the block hard to use.
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Drawings tree — blocks and formats organised by project
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3.2 Inserting DIN sheet formats
DIN sheet formats are predefined sheets (A0, A1, A2, A3, A4) that frame the drawing for plotting. They
include a title block, an optional grid and the North arrow. The insertion process consists of five steps:

1
Open the dialog
Insert → Predefined block. The format and scale dialog appears.

2
Choose the size
Pick the format from the drop-down (A0, A1, A2, A3, A4). The dimensions in mm appear next to the
name.

3
Set the scale
Choose the drawing scale (1/500, 1/1000…). TopoCal resizes the sheet to fit the drawing area.

4
Add complements
Tick Draw grid and Draw North arrow if you want them included automatically.

5
Fill in the title block
A second dialog asks for the title block attributes (project, date, drawing number…).
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«Insert Predefined Block» window — setting up the DIN sheet
format

«Title Block Attributes» window — editable title block fields

Title block fields

Field Description

Project title Identifying name of the work or project.

Drawing designation Specific name of this plan within the project.

Project engineer Person responsible for the project.

Consultant Engineering firm or surveying office in charge.

Date Issue date of the plan.

Project / Reference No. Internal numbers for filing.

Drawing No. / Sheet Numbering within the drawings set.

Horizontal / Vertical scale Print scale for each axis.

Final result — plan with DIN A1 format and complete title block Comparison of DIN sizes to scale — each format is half the
previous one
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3.3 PDF printing
Once the drawing is inside a DIN sheet format, you can print directly to PDF without any third-party
software. TopoCal includes its own PDF engine that preserves vectors, text and the title block.

1
Frame the drawing in the format
Make sure the drawing is correctly placed inside the inserted DIN sheet format.

2
File → Print
Open the print menu and choose Print to PDF.

3
Set the output
Pick the destination file, the format (A0–A4) and the elements to include.

4
Generate the PDF
Press OK. TopoCal generates the PDF and opens it in the default viewer.

«Print to PDF» dialog — output options Location sketch on DIN A1 format with main plan and key map
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REF Reference
Complete workflow · DIN sizes · compatibility

Recommended workflow

1
Survey
Take the field measurements with a total station or GNSS.

2
Import to TopoCal
Load the points, work the DTM and generate contours.

3
Draft the plan
Add blocks (trees, manholes, signage…) and texts.

4
Choose the DIN format
Insert the right size (A0–A4) based on the scale.

5
Fill in the title block
Complete project, date, reference and signatures.

6
Print to PDF
Generate the final PDF, ready to send or plot.

DIN sheet sizes

Format Width (mm) Height (mm) Area (m²)

A0 1189 841 1.00

A1 841 594 0.50

A2 594 420 0.25

A3 420 297 0.125

A4 297 210 0.0625

CAD version compatibility

CAD Versions Notes

AutoCAD 2010 – 2026 Full compatibility

ZWCAD 2018 – 2026 Full, except some hatches
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GstarCAD 2020 – 2026 Full, identical to AutoCAD

DXF R12 All Native import, no CAD needed

DXF > R12 All Requires CAD installed

■ Final reminders
Always back up the Blocks and Formats folders before reinstalling. If your blocks are in DWG or DXF later
than R12, you need a CAD installed to import them. The five DIN formats (A0–A4) cover every practical need:
choose the size based on the drawing scale, not the other way round.
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